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Introduction to QGIS (version 2.18) and Spatial Joins 
Rebecca Bartlett, GIS & Digital Resources Librarian, October 2018 

1. Download electoral wards for the City of Ottawa 
1) In an internet browser, go to http://data.ottawa.ca/.  

2) In the search bar, search for ward 

3) Select Wards 2014 

4) Click the Go to resource link for wards-2014:shp and download the shapefile 

5) Once it has downloaded, copy the ZIP folder into the project folder for today’s class. We suggest 

a hierarchy like this, but we’re particular about this stuff: 

 
6) Unzip the file. If you don’t, you may get an error when you try to import it into QGIS. 

7) Once unzipped, your folder should look something like this: 

 
This is as good a time as any to note that shapefiles look like multiple different files when you 

view them in Windows Explorer. If you ever copy and paste them somewhere, you need to have 

all the parts (e.g.: all the files that have the same name before the file extension – there may be 

up to 8 of them). For more on shape files, please consult pages 121 and 148 of The Data 

Journalist.  

8) You’re done the download!  

9) Open QGIS. Once QGIS opens, add the dataset by clicking on Layer > Add Layer > Add Vector 

Layer… Browse to the project’s folder and find the shapefile. Click on the “.shp” and click Ok to 

add the shapefile to QGIS’ data frame, which is the space to the right. 

a. You could also have the project folder open in Windows Explorer or Finder and just drag 

and drop the “.shp” file in. Either way works! 

10) You should now see the Ottawa wards, and it should look something like this: 

http://data.ottawa.ca/
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11) Click View >Panels and make sure Browser and Layers are both selected. If one of those options 

is unselected, then check the box beside it so the panel appears in the menu to the left.  

2. Adding the pedestrian collision data 
What we’ll do now is add a spreadsheet of vehicular collisions involving pedestrians that includes X and 

Y coordinates measured in metres. 

1) Open zip folder that contains Excel file Pedestrians hit by Ottawa ward 2014-2017.xlsx  

2) Note the “Pedestrian Condition” column on the far right 

3) Filter the field to include only pedestrian collisions (tip: everything but blank entries in that field) 

4) Copy those entries to a new sheet or Excel file 

5) Save that sheet/file as a CSV file, such as PedestrianCollisions_2014-2017.csv 

6) In QGIS, click Layer > Add Layer > Add delimited text layer 

7) In the dialog box, ensure the following items are entered: 

a. File format: CSV 

b. Geometry definitions: Point coordinates – X field is X-Coordinate and Y field is Y-

coordinate 

c. Geometry CRS is EPSG 32189 (search for 32189) NOTE: depending on what version of 

QGIS you’re using, the interface might be slightly different. The key is making sure the X 

and Y coordinates are properly identified, otherwise the points won’t appear on the 

map situated in the Qgis data frame.  

http://www.davidmckie.com/Pedestrians%20hit%20by%20Ottawa%20ward%202014-2017_Tutorial.zip
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8) Click Add, then Close. The points should now be visible over the wards: 

 
9) Although the points in the CSV file are displayed, we want to save them as a shapefile to 

conduct analysis. Right-click on the PedestrianCollisions_2014-2017 csv file and select “Save 

As…”. Give the file a name and make sure that the Coordinate Reference System (CRS) is EPSG 

32189 (it should be the default). 

https://docs.qgis.org/2.14/en/docs/gentle_gis_introduction/coordinate_reference_systems.html
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10) Once the new shapefile of pedestrian collisions is added to the map, remove the CSV file from 

the map. 

3. Changing the projection of the Wards shapefile 
Because what we’ll be doing is counting how many pedestrian collisions occur in each ward, it is best 

practice to have all the files used in the analysis in the same projection. We will convert the wards 

shapefile to the same projection as the collisions we just added. 

1) Right-click on the wards-2014_shp file and Save As… 

2) In the dialog box, we want to make sure that the CRS is the same as the pedestrian file. In the 

CRS drop-down list, EPSG:32189 – NAD83/MTM zone 9 should be visible since we already used 

it in this QGIS document. Click it. 

3) Browse to your project folder, name the file something helpful, and click OK. 



Prepared by Rebecca Bartlett, October 2018 5 

 
4) Once the new projected wards file is in the Layers list, remove the wards-2014_shp file.  

 

4. Add a basemap 
A basemap is a pre-made map that you can add to your QGIS document so that roads, water, and other 

features are visible. It is a helpful way to let you know if your shapefiles are in the right location to get 

your bearings. 

One thing to point out is that we’re adding the basemap after changing the projections as, generally 

speaking, web basemaps will adjust to the shapefiles (called “projecting on-the-fly”). However, if you 

add the basemap first, the shapefiles may project on-the-fly to the basemap’s projection. 

1) Go to Plugins > Manage and Install Plugins 

2) Search for “openlayers” (all one word). Find “OpenLayers Plugin” in the list, click it, and then 

click Install Plugin. 
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3) Wait a moment while it downloads and installs, then Close the dialog box. 

4) To access the OpenLayers Plugin, go to Web > “OpenLayers plugin”. You’ll see a list of map 

options, from Google to Bing to OpenStreetMap. 

 
5) Select an OpenStreetMap from the list. (Bear in mind that since we’re using an older version of 

the software, some of the options may not be available anymore.) Wait a moment or two for it 

to load. You may also need to click on the layer and move it to the bottom of the Layers list. 
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5. Finding out how many pedestrian collisions occurred in each ward 
A spatial join is done by using GIS software to count how many (in this case) points fall within each 

individual polygon. It’s like having a dozen chocolate chip cookies and the computer counting how many 

chocolate chips (collision locations) are in each cookie (ward). 

1) In QGIS, go to Vector > Analysis tools > Count points in polygon… 

2) NOTE: If you don’t have a “Count points in polygon” option you can use the “Join attributes by 

location option that can be found by going to Vector  > Data Management Tools  > Join 
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attributes by  location 

 
a. Target vector layer: wards-2014 

b. Join vector layer: OttawaPedestrianCollisions 

c. Geometric predicate: “contains” 

d. Attribute summary: select the “Take summary of intersecting features” option from the 

drop-down menu  

e. Statistics for summary: “sum” 

f. This process will generate a COUNT field at the far right of the attribute table (NOTE: 

the EPSG is different in the above screen shot than the ones used for the points-in-

polygon option below. The key is making sure the coordinate systems are the same.) 

3) If you have the “Count points in Polygon option, then you can skip the second step. 

4) Ensure the following details are correct in the dialog box (which may look slightly different, 

depending on what version of QGIS you’re using): 

a. Polygons: projected wards shapefile (should show that [EPSG:32189]) 

b. Points: pedestrian collisions shapefile (should show [EPSG:32189]) 

c. Count field name: NUMPOINTS (or rename it if you’d like) 

d. Check off Open output file after running algorithm 
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5) Click Run. If necessary, close dialog box when it’s done. 

6) A new Count file should appear in Layers. Open the attribute table. At the far right of the table 

will be a NUMPOINTS field that indicates how many collisions occurred within that ward. 

 
7) The new Count file is temporary, so save the Count file as a shapefile 
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8) Once the shapefile is in your layers list, you can open the attribute table to view the number of 

pedestrian collisions in each ward in the NUMPOINTS column. Click the column title to sort the 

values in ascending and descending order: 
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6. Symbolizing the wards with pedestrian collisions 
1) To symbolize based on number of pedestrian collisions, right-click on the 

WardCollisions_2014_2017 shapefile and select Properties. 

2) Click the Style tab in the Layer Properties dialog box. 

3) Click Graduated in the drop-down box at the top 

4) For Column, select NUMPOINTS  

 
5) Select a colour ramp, then click the Classify button  

6) It should be filled in as you see below: (NOTE: depending on your version of QGIS, your dialog 

box may look slightly different.) 

 
a. Under the Classes tab, Mode should be Natural Breaks (Jenks) with 5 classes 

i. You can play around with this if you’d like 

b. Pick your favourite colour ramp. As you are showing intervals, go with something that’s 

the same hue, but with varying intensity. If you go with a many-coloured ramp your map 

becomes meaningless, like so: 
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7) Your on-screen map should now look something like this, with the darker hues showing us which 

wards have higher and lower counts of pedestrian collisions. 

 
8) You can also manually adjust the intervals. For example, you can set the classes to 5 and then 

edit the values to reflect rounder numbers, like so: 
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You can also edit the legend text, as you can see above (eliminated decimal points). 

 

9) Adding labels is also done in Properties. Click the Labels tab and include the following settings: 

a. Show labels for this layer (top dropdown) 

b. Label with: WARD_NAME_ 

c. Click Apply 

 
10) You’ll notice that the labels can be hard to read. There are multiple ways to make labels easier 

to read but for this example, we’ll add a text buffer: 

a. Click the Buffer icon below Text (middle left of the Properties > Style dialog box) 

b. Check Draw text buffer 

c. Size: 0.5 millimeters 

d. Color: white (default) 

e. Transparency: 50% 

f. Click Apply 
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11) There are dozens of settings, but this is a good start until we create our map layout later on. 

 

7. Download Federal Electoral District shapefile and add to map document 
338 Federal Electoral Districts (FEDs) cover all of Canada and can be useful when looking at the whole 

country in smaller pieces than provinces and territories, but still are a reasonable number to deal with. 

Each FED is an area represented by one Member of Parliament. The data is downloaded as a shapefile 

which can then be viewed in QGIS. 

1) In an internet browser, go to statcan.gc.ca. 

2) After you’ve selected English, click Census program tab in the horizontal menu bar at the top 

 
3) Scroll down and under Information and services, click on Geography 

4) Scroll down to Spatial information products and click Boundary files 

5) In Boundary files options, select English and ArcGIS (“.shp”) format 

6) Select census year 2016 

7) Click the radio button for Federal electoral districts (2013 Representation Order) and 

Cartographic Boundary File, and then the Continue button 

8) Click the lfed000b16a_e.zip (ZIP version, 32,065.0 kb) link 

http://www.statcan.gc.ca/
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9) Unzip it and add the “.shp” to QGIS 

10) To see only the borders of the FEDs so you can view what areas are within them, we’ll use the 

following symbology: 

a. Keep the lfed000b16a_e file at the top of the layer list 

b. Right-click the layer and select Properties 

c. In the Styles tab, keep the Single symbol and Simple fill 

d. Click on Simple Fill. New options will appear below. 

i. Fill color: check the Transparent Fill box at the top 

ii. Stroke color: select whichever colour you’d like 

iii. Stroke width: 3 and select Points in the drop-down menu 

 

e. Click Apply 

f. You should now have fairly thick borders indicating where the FED boundaries are. 
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8. Creating a Map Layout 
To create a map layout in QGIS, you need to make a Composer. This will enable you to place and arrange 

map elements such scale bar, a legend, and a map title.  

1) Start off by right-clicking the layer you want to create a layout for, and select Zoom to layer. 

2) In the menu, select Project > New Print Composer.  

3) In the Composer title dialog box, give your new composition a name. Click OK. 

4) A new Composer window will appear. Under Page size > Presets, find and select ANSI A (Letter; 

8.5x11 in) 

5) To add your map of wards and pedestrian collisions, click Layout > Add Map, then draw a box 

that is just inside the perimeter of the page. 
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6) Under Item Properties tab, under Extents, click the Set to map canvas extent button to centre 

the layer. 

7) If the wards are either too large or too small for your liking, fiddle with the Scale under Item 

properties on the right.  

a. A larger number will make the wards smaller and a smaller number will make the wards 

larger. 

8) The QGIS composer is remarkably finicky. Maneuver (including deleting and re-adding) the map 

around until you’re reasonably satisfied. 

9) The labels we added earlier may also become an issue: some aren’t showing, they’re too small, 

etc. You can go back and forth from the Composer and the main QGIS map window to adjust the 

Properties and finesse the labels. 

a. If you make any changes, you need to go to Item Properties > Update Preview to 

refresh the map image 

 

Adding Other Map Elements 

Adding a Legend 

1. In the menu, select Layout > Add Legend.  

2. Draw a box where you would like your legend to appear. 
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3. By default, all the layers on the map will appear as legend items in the legend.  

4. To remove a legend item, you need to uncheck the Auto update checkbox and then 

manually remove the layers you don’t want in your legend using the red minus 

button.  

5. To change the name of a legend item as it shows up in the legend, click the 

legend item and then the Edit button to change its title in the legend.  

6. If you would like to change the title of your legend (or prefer that it doesn’t have a title at all), 

change it in the Title textbox under Main properties. 

7. There are a lot of options in the Legend panel, from font selections to spacing to background 

colour. 

8. You can click and drag the legend into place on your map. 

Adding a North Arrow 

1. In the menu, select Layout > Add Image. 

2. Draw a box where you would like to see your north arrow. 

3. In the Item properties panel on the right, click on the Search Directories submenu, and under 

Image search paths find the one ending in /arrows. 

4. Select an arrow that meets your needs. You could always design your own if you feel creative, or 

just go for a Star Trek vibe (never a bad idea): 

 

Adding a Scale Bar 

1. In the menu, select Layout > Add Scalebar. 

2. Draw a box where you would like to see the scale bar. 

3. In the Item properties tab, you can select one of six styles under the Style dropdown. 

4. Choose the units for the scale bar under Units. 

5. Adjust the segments in the Segments area. 

a. E.g.: left 0 and right 4 on a Line Ticks Up style will look something like this: 

 
6. Click and drag the scale bar into place on your map.  

Adding a Title to a Map 

1. In the menu, select Layout > Add Label. 

2. Draw a box where you’d like your title to be (you 

can move it later). 

3. Type your title into the Main properties text box. 

4. Adjust the font as you see fit and move it around 

until you resign yourself to the lack of design 

elements included in QGIS. 
This is not a very pretty map. You can make a nicer one. 
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