
 

Introduction 
The following workshop uses QGIS 3.4 (long-term release) for Mac, which was downloaded from here: 

https://qgis.org/en/site/forusers/download.html 

Adding Census Data and Census Boundary Layer 
The data that we’ll be using today can be found here - Workshop Data 

The census data was downloaded from the 2016 Census webpage and includes statistical data as well as 

geospatial layers. The following steps will outline the steps to add the statistical data to QGIS as well as 

adding corresponding census geospatial boundary layer for the accompanying data. We’ll be looking at 

the data at the Federal Electoral District (FED) level, which corresponds to a Federal riding for the 

federal elections. 

Step 1: Add Census Tabular Data 
1) In QGIS, go to Layer > Add Layer > Add Delimited Text Layer…  to add the comma-separated 

values (.csv) to QGIS. The software will preview the corresponding data.  
2) Fill in the following information then click OK 

a. File format: CSV 
b. Geometry definition: No geometry (attribute only table) 

c. Encoding: windows-1252 IANA 
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https://qgis.org/en/site/forusers/download.html
http://madgic.library.carleton.ca/deposit/workshops/Journalism/WorkshopData.zip


 

3) This will add the census data table to the table of contents. 

 

Step 2: Add Census Boundary Layer 
1) In QGIS, add the census boundary layers by clicking on Layer > Add Layer > Add Vector Layer… 

Browse to the project’s folder and find/add the lfed000b16a_e.shp by clicking on it and 

selecting Ok. 

a. You could also have the project folder open in Windows Explorer and just drag and drop 

the file in. Either way works! 
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Joining Census Data to Census Boundary Layers 
Our next step is to do an attribute join of the data. This can only be done when fields from our data and 
boundary layer are the same type and the values in each column correspond to one another. 

Step 1: Ensure Proper Field Type 

1) Right click on the lfed000b16a_e and Open Attribute Table. Right click on the CensusData and 
Open Attribute Table. Look at the data and try to determine which field from both files could be 
used for a join. 

2) Right click on lfed000b16a_e again, but this time, select Properties. On the left tabs, select 
Source Fields. This should tell you the field type for every field in your data. Looking here, the 
field type for FEDUID is String. 

3) Right click on CensusData again and select Properties. On the left tabs, select Source Fields. This 
should tell you the field type for every field in your data. Looking here, the field type for 
FEDCODE is Integer. 

As you can see, the field types don’t match. We’ll be changing the field type for CensusData. 

4) Right click on CensusData and select Open Attribute Table 
5) Select the Open Field Calculator Icon 

 

6)  In the field calculator, do the following calculation and click Ok. 
a. Output field name: FEDid 
b. Output field type: Text, unlimited length (text) 
c. Expression: “FEDCode” 
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7) This will create a new text field with the data from the FEDCode field. We’ll then be able to do 
our join with this newly created field since it’s the same field type as the boundary layer. 
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Step 2: Attribute Join 
 

1) To do our attribute  join, right click on lfed000b16a_e and select Properties. From the 
Properties window, select Joins and click on the green + button at the bottom left of the 
screen.  
 

 
 
 
Fill in the corresponding information to perform the join. Ensure you select Custom Field Name 
Prefix and remove the text in that box. This will keep the 
original field names from the CensusData. 
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2) Click Ok. 

 
3) Right click on lfed000b16a_e > Export > Save Features as… Change format to Esri Shapefile and 

click on the three dots next to the File name box and navigate to a folder to save the file as 
FED_Census_Data.shp. The join is now permanent.  

 

Step 3: Explore the Joined Data 
1) In the table of contents, right click on FED_Census_Data and select Open Attribute Table. You 

should now see the additional census data in your layer file.  
2) Remove the lfed000b16a_e and the CensusData from the table of contents. You should have 

only the FED_Census_Data in the table of contents. 

Now that our attribute data is joined to our geospatial file, we are now ready to begin mapping! 
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Style and Labels Your Map 
To better visualize our census data, we’ll use different colours and labels for our map. Before doing so, 
we’ll adjust how our column headers look, since the column names aren’t clearly labelled.  

Step 1: Create Field Alias 

1) Right click on the FED_Census_Data polygon file and select Properties…  
2) Click on the Attributes Form tab 
3) You will see a list of all the fields. Click on a field and input text in the Alias field to something 

helpful for each field. Feel free to use the table that explains the census data variables to set a 
proper alias. Click Ok when done. 
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Step 2: Change the Style of the Map 
Now, we’ll change the style of FED_Census_Data to visualize and represent the population change from 

2011 to 2016 

1) Right click on FED_Census_Data and click on Properties select the Symbology tab from the left. 

2) At the top, change the symbol single symbol to Graduated. 
3) Under column, select MedianIncome...or MedianInco 

4) Click on the colour ramp and select YlOrRd. 

5) Change the Mode to Natural Breaks (Jenks) and click on Classify.  
6) Click Ok 
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Step 3: Add Labels to the Map 

In this section, we’ll learn how to add labels to our map. 

 

1) Now let’s label each FED with the name of the FED. 

2) In Properties, select the Labels tab. 

3) In the top bar change No labels to Single labels 

4) In Label with and set the label field to FEDENAME 

5) Choose your label font. In the example it’s Arial, size 12, bold, black. 

6) Click OK. 
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7) Your map should now look something like this. You’re visualizing the after-tax median income 

and have the Federal Electoral Districts labelled. Give yourself a pat on the back! 
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Select by Attribute 
Next, we just want to select the Federal Electoral Districts for both Alberta and British Columbia. We will 

do this by selecting particular attributes 

1) In the table of contents, right click on FED_Census_Data, click on Open Attribute Table. 
2) Once the table open, select the Select Features using an Expression button 

 

3) Type in the following formula:  "PRUID"  LIKE  '48'  OR  "PRUID"  LIKE   '59'  

4) Click Select Features in the bottom right corner 

 

This will select both the province of British Columbia (59) and Alberta (48). 

4. Right click on FED_Census_Data  > Export > Save Selected Features as… Change format to Esri 

Shapefile and ensure that Save only selected features… is selected. Click on the three dots next to the 

File name box and navigate to a folder to save the file as AlbertaBC_FED_Data.shp.  
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Add x,y data 
In the first part of the exercise, we added a.csv file and visualized it by conducting an attribute join. In 

the following section, we’ll visualize our .csv file by displaying its x,y coordinates. 

1) In QGIS, go to Layer > Add Layer > Add Delimited Text Layer…  to add the comma-separated 
values (.csv) to QGIS. The software will preview the corresponding data.  

2) Fill in the following information then click OK 
a. File format: CSV 
b. Under Record and Fields Options | Number of header lines to discard = 0 (first record 

has feild names) 
c. Geometry definition: Point coordinates 

i.  x field = longitude, y field = latitude 
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3) Right click on the pipelines incident in the table contents and select Export > Save features as… 

4) Save the file and ensure that you change the coordinate reference system (CRS) to EPSG: 3347. This 

will allow us to conduct additional geoprocessing moving forward. We’ve save it as 

PipielinesLambert.shp 
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Clipping 
Our next exercise will allow us to focus on a smaller geographic region, British Columbia and Alberta.  

1) In the menu click on Vector > Geoprocessing Tools > Clip. 
2) Fill in the information as outlined below. You’ll be using the boundary file for AlbertaBC_FED to 

cookie cut the PipelinesLambert. Click Run 

 

14 
Joël Rivard, Meaghan Kenny - Fall 2019   

 



 

 

3) The newly created Clipped file will be added to the table of contents. Feel free to rename this by 

right clicking on it and selecting rename. I’ve renamed it Pipelines Alberta BC. 

Let’s clean-up our table of contents and remove unwanted layers. Let’s remove the following layers by 

right clicking on each and selecting remove: 

● Pipeline_Incidents 

● FED_Census_Data 

We should now be left with Pipelines_AlbertaBC and AlbertaBC_FED. 

Spatial Join 
A spatial join allows us to combine information from multiple layers that cover the same geographic 

footprint. For this analysis, we want to know how many pipeline incidents (points) exist in each FED 

(polygon).  

1) In the menu, select Vector > Analysis > Count Points in Polygons. 

2) Select the following parameters. 
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This will add a count field as well as add the number of pipeline incidents for each federal electoral 

district. The name of layer in the table of contents with be Count. Feel free to change that to something 

a bit more meaningful such as PipelinesCountFED (right click on the file > rename). 

 

Style & Labels (again!) 
Now, we’ll change the style of PipelinesCountFED to visualize and represent the electoral districts by 

after-tax income and the number of pipeline incidents. 

Step 1: Change the Style of the Map 
1) Right click on PipelinesCountFED and select the Symbology tab from the left. 

2) At the top, change the symbol single symbol to Graduated. 
3) Under column, select AfterTaxIn. 

4) Click on the colour ramp and select YlGN. 

5) Change the Mode to Natural Breaks (Jenks) and click on Classify.  
6) Click Ok. 
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Step 2: Add Labels to the Map 

In this section, we’ll add labels to our map. 

 

1) Now let’s label each FED with the number of pipeline incidents. 

2) In Properties, select the Labels tab. 

3) Select Show labels for this layer and set the label field to Count 

4) Choose your label font. In the example it’s Arial, size 12, bold, black. 

5) Click OK. 
 

Our final should look like this. Each FED is colour-coded to represent the median income and labelled to 

show how many schools in each FED. 

 

Feel free to change which variable to map instead of income. Maybe language? 
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Export the Map 

1) When your ready to export your map, click on Layout > Export as Image or Export as PDF. 
2) Select the name for your output map and click ok. 

3) Your map should now be saved as an Image or a PDF. 

 

 

Bonus: 

In this bonus section, we’ll get students to add the voting results by electoral districts for the 2015 

federal election. 

1) Download Table 11: Voting results by electoral district from Elections Canada’s website. This 

is a .csv file. 

2) Add the .csv file to QGIS (see previous steps on how to add a .csv) 

3) Conduct an attribute join using the FED code as the common field. Make sure you have the 

correct field type. Don’t forget to export your newly join data to a new shapefile. 

4) Symbolize and label your new layer. 
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https://www.elections.ca/res/rep/off/ovr2015app/41/data_donnees/table_tableau11.csv

